Current configuration : 1241 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service tcp-small-servers
!
hostname samhrc
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip name-server [填上DNS 地址]
!
interface Serial0
ip address 192.168.1.1 255.255.255.0 [本地的路由器IP和掩码]
ip mtu 1492 [MTU 不解释了]
ip nat inside
no ip route-cache
ip tcp adjust-mss 1442
pppoe enable
pppoe-client dial-pool-number 1 dial-on-demand
!
interface Ethernet0
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer-group 1
ppp authentication pap callin
ppp pap sent-username [你的ADSL用户名] password [你的口令]
ip nat inside source list 100 interface Dialer1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any (可以访问的IP 没有的话不设置这一段)
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
transport input all
line vty 0 4
!
end